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QUESTION 1 (48 Marks)

(a) 
SP is a register that can be used as a pointer to a stack in memory. Rj is any register in a processor's register file. Load, Add, Subtract and Store are ISA commands in a RISC architecture. Write down the instruction sequences that implement the pseudocode 
1. PUSH Rj

Subtract SP, SP, #4
Store Rj, (SP)

 and 
       
2. POP Rj

Load Rj, (SP)
Add SP, SP, #4

(b) 
Describe briefly how a memory operand can be addressed in a generic RISC computer Load instruction. Give one example. 4 Marks

· The address can be formed from the contents of a register and a value located immediately within the instruction. 
· If absolute addressing is required, R0 can be named as the register. 
· In RISC machines, R0 normally contains 0. 
· If only the value contained in the register is required, a constant value of 0 can be used.
·  In any case, the effective address is the sum of the register contents and the constant.

Load R1, 8(R7)  ,  R1 <- [M<[R7]+8>]











(c)
 Describe briefly what is being done by the following RISC code sequence, 4 Marks

Move R2, #LOC
LoadByte R3,(R2)
LShiftL R3,R3,#4
Add R2,R2,#1
LoadByte R4,(R2)
And R4,R4,#0xF
Or R3,R3,R4
StoreByte R3,PACKED 

· Binary Coded Digit Packing
· Memory  has two binary-coded decimal digits.
· Pointer set to 1st byte for index-mode access to load 1st digit, which is shiftd to upper bits. 
· Upper bits of 2nd digit are cleared by ANDing
· ORing combines 2nd digit with sshifted 1st digit for result of two packed digits in a single byte.
· 32-bit registers, but only 8 lowest bits relevant.

Move R2, #LOC		R2 points to data
LoadByte R3,(R2)		Load first byte in R3
LShiftL R3,R3,#4		Shift left by 4 bit positions
Add R2,R2,#1		Increment the pointer
LoadByte R4,(R2)		Load second byte in R4
And R4,R4,#0xF		Clear high-order bits to zero
Or R3,R3,R4		Concatenate the BCD digits
StoreByte R3,PACKED 	Store the result

 (d) 
Write down the sequence of instructions that will put the 32-bit value 0x20004FF0 in register R2. Why is more than one instruction needed to do this? 4 Marks

· 

OrHigh R2,R0,#0x2000
Or R2,R2,#0x4FF0  
   

· 2 instructions are needed because a single instruction is only 32 bits long and therefore cannot contain a 32-bit immediate value












(e) 
An output display interface has a status register DISP_STATUS in which bit 2 is set when the output buffer is empty following transmission of a character to the display and cleared when DISP_STATUS is read by a program. Write an instruction loop, WRITEWAIT, to wait for an appropriate display status before writing a character to DISP_DATA. 4 Marks

· 

	WriteWait
		LoadByte	R4, DISP_STATUS
		And		R4, R4, #4
		Branch_if_[R4}=0	   WRITEWAIT
		StoreByte	R5, DISP_DATA

(f) 
A display output routine, WRITECHAR, is executed when an interrupt is received from the keyboard. Briefly outline the structure of the routine and the difference between it and the approach in part (e) above. 4 Marks

· WRITECHAR is an ISR. Its address is centered in the interrupt vector at initialisation. The keyboard interface is wired to the corresponding interrupt level through an interrupt controller.
· WRITECHAR has no wait loop. Once it is called, it is certain that KBD_DATA is empty and available for transmission of new a character  to the display. Hence, the first 3 lines of WRITEWAIT are irrelevant. WRITECHAR must save any destroyed registers, resotre them at the end and finish with an interrupt return. 
· WRITECHAR:
	Save registers
	StoreByte 	R5, DISP_DATA
	Restore registers
	I_return

 (g) 
An interrupt routine need to use registers R2 and R5 to contain a buffer address PNTR and an 8-bit value INDATA respectively. Write the instruction sequence to save these registers on the stack, put the PNTR and INDATA values in the registers and save the 8-bit value in the buffer addressed by PNTR. You may assume that the stack pointer, SP, has already been initialised.
4 Marks

· 

Subtract 	SP, SP, #8
Store 	R2, 4 (SP)
Store 	R5, (SP)
Load 		R2, PNTR
LoadByte	R3, INDATA
StoreByte	R3, (R2)
	





(h) 
Describe, in words, the four steps into which execution of the instruction ADD R3, R4, R5 can be subdivided. Why might an additional step be required for some instructions? (4 Marks)

· 


1. Fetch the instruction and increment the program counter.
2. Decode the instruction and read registers R4 and R5.
3. Compute the sum [R4] + [R5]
a. ****
4. Load the result into the destination register, R3.

· For instructions requiring memory access, a fifth step would be inserted at 3a. RISC machines do not combine ALU instructions with memory access. 

(i) 
List the 5 actions into which execution of a general instruction can be divided. List the five corresponding hardware stages. 4 Marks

· 

1. Fetch an instruction and increment the program counter.
2. Decode the instruction and read registers from the register file.
3. Perform an ALU operation
4. Read or write memory data if the instruction involves a memory operand.
5. Write the result into the destination register

· Stages are Instruction fetch (IF), Decode and access register file (D), ALU, Memory access (M) and writeback to register file (WB).



















(j) 
Show in one diagram a conceptual view of the ALU segment of a RISC data path. Include input registers, output registers and any necessary multiplexers. Briefly outline the component functions. 4 Marks

· 

[image: ]

(k) 
Write a short paragraph on oscilloscope probe compensation as practised in your laboratory sessions. Sketch overcompensated, undercompensated and correctly compensated waveforms. 4 Marks



















(l) 
List the actions necessary in order to start up and run an Arduino Due sketch. (4 Marks)

· Connect the Arduino to its programmer and connect the programmer to the host via a USB cable
· Launch the Arduino application
· From the “Tools” menu, select the Arduino Due
· From the list of serial ports offered on the “Tools” menu, select “COMx” when ... number greater than 1.
· From the “Tools” menu, select “Programmer -> AVRISP mk11”
· From the “File” menu, select the sketch
· The sketch opens on its own Arduino window
· Click on the “Upload” arrow in the sketch window
· The sketch loads onto the Arduino card and executes 


































QUESTION 2 (32 Marks)

Use the following code sequence in part (a) of this question:

1. const int buttonPin = 2;
2. const int ledPin = 13;
3.
4. int buttonState = 0;
5.
6. void setup() {
7.
8. pinMode(ledPin, OUTPUT);
9.
10. pinMode(buttonPin, INPUT);
11. }
12.
13. void loop(){
14.
15. buttonState = digitalRead(buttonPin);
16.
17.
18.
19. if (buttonState == HIGH) {
20.
21. digitalWrite(ledPin, HIGH);
22. }
23. else {
24.
25. digitalWrite(ledPin, LOW);
26. }
27. }

(a) 
Explain what this program does when it is uploaded to an Arduino card. Explain the purposes of lines 6, 10 and 13. What external circuitry would you use in connection with this sketch and how would you connect it? 9 Marks



(b) 
The Arduino Due is based on an Atmel AT-SAM3X8E processor which itself contains an ARM Cortex M3 core. What is the maximum clock rate of the SAM3X?

Describe the physical memory available on the Arduino AT-SAM3X. Give a general account of the Cortex-M3 architecture.  (9 Marks)

(c) 
Describe bit banding in the context of the ARM Cortex-M3 (7 Marks)

Bit-banding maps a complete word of memory onto a single bit in the bit-band region. For example, writing to one of the alias words sets or clears the corresponding bit in the bit-band region. This enables every individual bit in the bit-banding region to be directly accessible from a word-aligned address using a single LDR instruction. It also enables individual bits to be toggled without performing a read-modify-write sequence of instructions.

The processor memory map includes two bit-band regions. These occupy the lowest 1MB of the SRAM and Peripheral memory regions respectively. These bit-band regions map each word in an alias region of memory to a bit in a bit-band region of memory.

The System bus interface contains logic that controls bit-band accesses as follows:
[bookmark: _GoBack]
· It remaps bit-band alias addresses to the bit-band region.
· For reads, it extracts the requested bit from the read byte, and returns this in the Least Significant Bit (LSB) of the read data returned to the core.
· For writes, it converts the write to an atomic read-modify-write operation.
· The processor does not stall during bit-band operations unless it attempts to access the System bus while the bit-band operation is being carried out.

The memory map has two 32-MB alias regions that map to two 1-MB bit-band regions:

· Accesses to the 32-MB SRAM alias region map to the 1-MB SRAM bit-band region.
· Accesses to the 32-MB peripheral alias region map to the 1-MB peripheral bit-band region.

A mapping formula shows how to reference each word in the alias region to a corresponding bit, or target bit, in the bit-band region. The mapping formula is:

bit_word_offset = (byte_offset x 32) + (bit_number × 4)

bit_word_addr = bit_band_base + bit_word_offset

where:
· bit_word_offset is the position of the target bit in the bit-band memory region.
· bit_word_addr is the address of the word in the alias memory region that maps to the targeted bit. 
· bit_band_base is the starting address of the alias region.
· byte_offset is the number of the byte in the bit-band region that contains the targeted bit.
· bit_number is the bit position, 0 to 7, of the targeted bit.

Figure 3.2 shows examples of bit-band mapping between the SRAM bit-band alias region and the SRAM bit-band region:
· The alias word at 0x23FFFFE0 maps to bit [0] of the bit-band byte at 0x200FFFFF: 0x23FFFFE0 = 0x22000000 + (0xFFFFF*32) + 0*4.
· The alias word at 0x23FFFFFC maps to bit [7] of the bit-band byte at 0x200FFFFF: 0x23FFFFFC = 0x22000000 + (0xFFFFF*32) + 7*4.
· The alias word at 0x22000000 maps to bit [0] of the bit-band byte at 0x20000000: 0x22000000 = 0x22000000 + (0*32) + 0*4.
· The alias word at 0x2200001C maps to bit [7] of the bit-band byte at 0x20000000: 0x2200001C = 0x22000000 + (0*32) + 7*4.

(d) 
Describe the ARM Cortex-M3 Memory Map (7 Marks)

QUESTION 3 (32 Marks)

(a) The Intel Galileo board is an Arduino-compatible system based on the Intel Quark SoC X1000 Core. Give an overview of the memory layout. Draw a block diagram of the address translation mechanism.  (10 Marks)

(b) Give an account of the operating modes of the Quark core.  (10 Marks)
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PG (Paging Enable, bit 31)
The PG bit is used to indicate whether paging is enabled (PG=1) or disabled (PG=0). (See Table 10.)

PE (Protection Enable, bit 0)
The PE bit enables the segment based protection mechanism when PE=1 protection is enabled. When PE=0 the Intel® Quark SoC X1000 Core operates in Real Mode. (Refer to Table 10.)

(Source: https://communities.intel.com/servlet/JiveServlet/previewBody/21826-102-2-25118/Intel%20Quark%20Core_DevMan_001.pdf)

(c) Based on your experience and knowledge of RISC and CISC processor design, write a short technical essay comparing the Intel Quark with the ARM M3 from the point of view of suitability for use in embedded systems.  (12 Marks)


· Clocks
· Architectural Approach
· Memory Layout
· Use of pipelines
· Cache
· LE Cache
· Cache-less Processor

Clock speed faster for the Quark, there is reason to believe that because the other processor has a RISC, straight off it doesn’t need to do any translation or interpretation of complex instruction sets.
Memory access is extremely complicated on the Quark, you also have a Level 1 Cache, and this will discourage us as we have instructions and data coming from the same cache. ARM C3 cache doesn’t have any cache, the architecture on which it is based is designed specifically to be a cache-less processor – two separate memories, one for instructions and one for data – within the core the is no cache – you could say that it is a unified cache so you are going to get conflicts.

In conclusion I would choose the Quark, it’s one-fifth the size and one-tenth the power of the new “Silvermont” Atom processor. 
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Table 10. Intel® Quark SoC X1000 Core Operating Modes

PG PE Mode
0 0 Real Mode. 32-bit extensions available with prefixes.
Protected Mode. 32-bit extensions through both prefixes and “default” prefix setting
0 1 associated with code segment descriptors. Also, a sub-mode is defined to support a virtual
8086 processor within the context of the extended processor protection model.
4 0 Undefined. Loading CRO with this combination of PG and PE bits causes a GP fault with
error code 0.
1 1 Paged Protected Mode. All the facilities of Protected Mode, with paging enabled undemeath
segmentation.
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